WordPress 5.4にアップグレード後の不具合

home

結論

・旧エディタで編集する

・キャッシュを削除する

ググる

内容は表題の通りで、アップデートの通知が来てたから更新したら、編集画面に飛ばない問題が発生したというものだ。
具体的には、

「エディターで予期しないエラーが発生しました。」

というエラーがブラウザに表示され、問題を修正する、記事のコピーなどと三つのコマンドが表示される。クリックはできるが、次のアクションが何も起きない状態。

wordpressのエディタはGutenbergが使われてるようで、色々とググってたら、旧エディタに戻す方法があった。「classic editor」っていうプラグイン。設定方法は簡単なので、他の記事とか参照してほしい。そこで設定すれば、不評なGutenbergではなくて、旧エディタで編集ができるようになる。個人的にはどちらでもいいが、最近だと編集もしやすい機能が追加されているようなので、人それぞれ好みがわかれるところだ。

少し脱線したが、これでclassic editorのプラグインを有効化すれば、確かにエラーは消え、編集はできるようになるが、ブロックエディタが拙い。

更新後の反映がされていないので、旧エディタではなく最新のものが使いたいという人にしてみれば問題の解決になっていない。この辺りは公式のサポートに書いてある。そちらを参照したい。
WordPress 5.4にアップグレード後の不具合(最終閲覧2020/04/04)
キャッシュを削除しろってこと。これで直るようだ。

basic

Posted by himajinn